Hasselblad Mirror lock up

Recent Classifieds

Forum statistics

Threads
177,163
Messages
2,430,370
Members
94,146
Latest member
shawnmcc
Recent bookmarks
0

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
Hasselblad Mirror lock up problem

So I just got my 500CM, I was trying the mirror lock up function on it but noticed that the primary shutter was opening as well when I hit the switch. It wasn't doing the selected shutter speed, it would just sort of half-open and then slowly close. After it was closed I could fire the primary shutter like normal. Is there anyway I could fix this? All the shutter speeds sound right when I fire the camera, and a polaroid I took came out alright. The lens is an 80mm CF.
 
Last edited by a moderator:
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
I tried it again and it seems that the mirror lock up function works fine when the lens' aperture is in the preview mode.
 

bdial

Subscriber
Joined
Jan 2, 2005
Messages
7,147
Location
North East U.S.
Shooter
Multi Format
Sounds like it has a problem.
When you hit the pre-release, it should close the shutter in the lens then the mirror goes up and the rear curtains open. When you press the shutter release the shutter should open and close, then on releasing the button the rear curtains will close.

Should work the same way whether or not the lens is in DOF preview mode.

Based on what you describe with your camera, I'd expect a fogged frame if you pre-release with film in a back.
 

itsdoable

Member
Joined
Aug 26, 2013
Messages
578
Location
Canada
Shooter
Medium Format
Is there any evidence of oil on the shutter leaves?

Take the film back off, and trigger the mirror lock up while peering through the film gate, do you see light as the shutter closes? You should not, if you do, then the shutter leaves are slow (usually due to oil contamination) and they need to be cleaned.

During mirror lock up, the primary leaf shutter does not "open", as it starts out opened (so you can see). It should close, before the light baffle in the body opens. If it does not close in time, it needs a service.
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
I don't see any oil on the shutter or aperture blades. It's shutter is snappy when fired normally and when the mirror lock-up is activated when the DOF preview is activated(or when I push the switch down just before the DOF is activated). So far all the shutter speeds sound like they are correct,
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
I did some more testing and found that at one second, f/22 the aperture blades would slowly close, then when they reached the right position, the shutter activated and closed a second later. So it looks like the lens needs servicing, all the fast speeds seems to work though, and the event I described only seems to happen after using bulb mode.
 

Tom1956

Member
Joined
May 6, 2013
Messages
1,990
Location
US
Shooter
Large Format
"All the speeds seem to work" is EBAY talk for "this lens needs CLA."
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
I'm sending it to David Odess today for a CLA. The lens is in good cosmetic shape though and I think I got a good price, even including what this repair is going to cost me.
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
Well the lens is still out for repair, David Odess has been backed up lately. Along with a CLA he's replacing the main spring and the mounting tube, which according to him" It is a part in the shutter that has two teflon bearings, and one of the bearings is cracked, effecting the operation of the shutter".
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
Got the lens back today, and the shutter closes and opens instantly now. David Odess does some good(albeit pricey) work. Unfortunately the mirror lock up problem is persisting. It's faster than it was before, but the shutter is still open when after the mirror goes up. Since the lens was just repaired(which it needed to be anyway) this leads me to believe the problem is the body. So I sent that back to KEH today and I'll see what they say.
 
Joined
Dec 4, 2012
Messages
67
Location
Charmouth, UK
Shooter
Medium Format
Well the lens is still out for repair, David Odess has been backed up lately. Along with a CLA he's replacing the main spring and the mounting tube, which according to him" It is a part in the shutter that has two teflon bearings, and one of the bearings is cracked, effecting the operation of the shutter".
I recognise the description of that fault, I would do the same, replacement of the mainspring is good sense
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
I recognise the description of that fault, I would do the same, replacement of the mainspring is good sense
Yup, the lens works great now. I took a couple of polaroids and they just look fantastic. The only lag is occurring during the mirror lockup, so my guess is the body's got a worn out spring somewhere, I'll see what KEH says.
 

pgomena

Member
Joined
Jun 25, 2003
Messages
1,391
Location
Portland, Or
Any repair to a Hasselblad is "pricey." Get used to it. You own the photographic equivalent of a Porsche or Mercedes. If you take care of your camera, it will function flawlessly. If you ignore maintenance and repairs, it won't work. Ignoring maintenance will create cascading problems that will cost even more to repair. I speak from experience.

David Odess gets backed up because he's a well-known and reputable repairman. He's also a one-man shop. He has repaired my Hasselblad, and I will send my business to him again in the future.
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
Any repair to a Hasselblad is "pricey." Get used to it. You own the photographic equivalent of a Porsche or Mercedes. If you take care of your camera, it will function flawlessly. If you ignore maintenance and repairs, it won't work. Ignoring maintenance will create cascading problems that will cost even more to repair. I speak from experience.

David Odess gets backed up because he's a well-known and reputable repairman. He's also a one-man shop. He has repaired my Hasselblad, and I will send my business to him again in the future.

I'm not complaining, David did great work on my lens. Guess it's just a shame that I start my Hasselblad experience with two pieces of gear that need repair. Luckily my 500C/M body is still under warranty from KEH.
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
Well, KEH couldn't replicate my problem, but they are exchanging my camera. So I guess if the mirror lock up issue continues on the new body, I'll just need to send the lens back to David Odess for adjustment.
 
OP
OP

Atari1977

Member
Joined
Dec 10, 2012
Messages
46
Shooter
Medium Format
I got my exchange from KEH today and the mirror lock up function works perfectly on this one, plus I got an upgrade to EX+ since they were out of EX grade ones. After about three months, I am happy to report that I now have a fully working Hasselblad 500cm setup! I took some polaroids and they just look fantastic, I can't wait to run some actual film through this thing.
 
Photrio.com contains affiliate links to products. We may receive a commission for purchases made through these links.
To read our full affiliate disclosure statement please click Here.

PHOTRIO PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Ilford Photo ADOX Freestyle Photographic Photo Warehouse Stearman Press Weldon Color Lab
Top Bottom