Hasselblad 201f - Mirror won't go all the way up

Discussion in 'Medium Format Cameras and Accessories' started by logan.egbert, Jan 27, 2017.

  1. logan.egbert

    logan.egbert Subscriber

    Messages:
    187
    Joined:
    Aug 24, 2010
    Shooter:
    Multi Format
    Hello All,

    I just bought a 201f from a reputable dealer (thank god) and unfortunately, I think it's DOA.

    You can see what I mean here.

    Does anyone know if this is a small fix I can do myself? Or should I just send it back. I know that David Odess and my local Hassy guy aren't keen on working on 200 series bodies, so I fear it's going to be heading back. Just want to make sure before I reach out to the shop.

    Thanks!
     
  2. If they will repair that camera at their cost, have them repair or exchange the camera.
    If they will exchange the camera, try the exchange.
    If they will not repair nor exchange the camera, return the camera.
     
  3. itsdoable

    itsdoable Member

    Messages:
    195
    Joined:
    Aug 26, 2013
    Location:
    Canada
    Shooter:
    Medium Format
    Check to see if the light baffle at the back of the mirror (near where it would hinge) has broken off, and is obstructing the mirror, preventing it from rising completely. It will look like a narrow strip of plastic stuck in the mechanism. You can also take out the focus screen to get a better view from that side.

    The lens key completes it's rotation, so the body is mechanically completing it's movement. That means the spring that pushes up the mirror is probably working, and something (either in the mirror box or in the mechanism) is preventing the mirror from completing the swing.

    For reference, this thread has a picture of the baffle (second page for close-ups) :
    (there was a url link here which no longer exists)

    If not this, then something else...
     
  4. OP
    OP
    logan.egbert

    logan.egbert Subscriber

    Messages:
    187
    Joined:
    Aug 24, 2010
    Shooter:
    Multi Format
    It doesn't look like the light baffle has broken off.
    IMG_1682.JPG IMG_1684.JPG

    It's so strange, it just won't push up to the focusing screen.

    Do you see something I don't?

    Thank you for the post!

     
  5. itsdoable

    itsdoable Member

    Messages:
    195
    Joined:
    Aug 26, 2013
    Location:
    Canada
    Shooter:
    Medium Format
    Baffle and parts look all right to me.

    If you gently push up on the mirror, will it complete it's travel, or dose it feel like something is stopping it?

    Could be the spring is weak, and can no longer complete the motion, and/or the mechanism has become a bit sticky.

    I think at this point, it's time to send it back for a proper check.
     
  6. Chris Livsey

    Chris Livsey Member

    Messages:
    646
    Joined:
    Aug 10, 2008
    Shooter:
    Medium Format
    I am not an expert in the 200 series, in fact I am short of any experience but in your clip you are releasing via a cable release, I just wondered if this had any significance at all and this link may help diagnosis and explains why i have never ventured down the focal plane Hasselblad route, good luck.
    http://photo.net/medium-format-photography-forum/00Wmi9
     
  7. aoresteen

    aoresteen Member

    Messages:
    537
    Joined:
    Jun 8, 2004
    Location:
    Newnan, GA,
    Shooter:
    Multi Format
    I'd replace the battery and see if a fresh one solves the problem.
     
  8. OP
    OP
    logan.egbert

    logan.egbert Subscriber

    Messages:
    187
    Joined:
    Aug 24, 2010
    Shooter:
    Multi Format
    I did, no dice :sad:
     
  9. OP
    OP
    logan.egbert

    logan.egbert Subscriber

    Messages:
    187
    Joined:
    Aug 24, 2010
    Shooter:
    Multi Format
    I think you're right!
     
  10. Chadinko

    Chadinko Member

    Messages:
    188
    Joined:
    Feb 3, 2016
    Location:
    Phoenix, AZ
    Shooter:
    Multi Format
    I think you have managed to get the only working half-frame Hassie! You should feel honored.

    But really, that sucks.
     
  11. aoresteen

    aoresteen Member

    Messages:
    537
    Joined:
    Jun 8, 2004
    Location:
    Newnan, GA,
    Shooter:
    Multi Format
    Any update? Did you have it serviced?
     
  12. OP
    OP
    logan.egbert

    logan.egbert Subscriber

    Messages:
    187
    Joined:
    Aug 24, 2010
    Shooter:
    Multi Format
    I did! I sent it off to Hasselbladbron and they did the repair. It wasn't cheap, but it came back working perfectly.
     
  13. Chris Livsey

    Chris Livsey Member

    Messages:
    646
    Joined:
    Aug 10, 2008
    Shooter:
    Medium Format
    Good news, Hasselblad-cheap = oxymoron :D
     
  14. GarageBoy

    GarageBoy Member
    Ads Enabled

    Messages:
    834
    Joined:
    Nov 5, 2012
    Shooter:
    35mm
    Who is hasselbladbron? How much was the CLA?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies. If you have a Photrio account, please log in (and select 'stay logged in') to prevent recurrence of this notice.