canon/sigma

Funky Face

A
Funky Face

  • 0
  • 0
  • 0
faded glory

A
faded glory

  • Tel
  • Oct 7, 2022
  • 0
  • 0
  • 0
Parkbench images

A
Parkbench images

  • 0
  • 0
  • 54

Recent Classifieds

Forum statistics

Threads
179,581
Messages
2,472,818
Members
94,843
Latest member
ocieb
Recent bookmarks
0
Joined
Dec 2, 2003
Messages
4
Shooter
35mm
i have a canon eos 30 and a canon 500n - i have attempted to buy a sigma 17-35m f2.8-4 ex lens to add to my kit as i thought it would be, as advertised, compatible with the canon bodies- not the case! - autofocus just wont operate - anyone any idea why?
regards
mic warmington
 

photomc

Member
Joined
Jul 20, 2003
Messages
3,575
Location
Texas
Shooter
Multi Format
mic, not trying to be rude..but have you verified that the lens is in autofous mode and not manual mode. If so, take one of your bodies to shop that has the lens and check to see how that lens..could be that you just got a bad lens.

Good luck.
 
OP
OP
Joined
Dec 2, 2003
Messages
4
Shooter
35mm
photomc said:
mic, not trying to be rude..but have you verified that the lens is in autofous mode and not manual mode. If so, take one of your bodies to shop that has the lens and check to see how that lens..could be that you just got a bad lens.

Good luck.

thanks for reply - 2 different lenses tried in two different shops with two different sets of assistants with everything checked - no joy - one assistant mentioned i might need another "chip" fitted - dont see why - again, any ideas????
mic
 
Photrio.com contains affiliate links to products. We may receive a commission for purchases made through these links.
To read our full affiliate disclosure statement please click Here.

PHOTRIO PARTNERS EQUALLY FUNDING OUR COMMUNITY:



Ilford ADOX Freestyle Photographic Stearman Press Weldon Color Lab
Top Bottom