Prontor SVS - only fires consistently in V (self-timer) now?

Discussion in 'Camera Building, Repairs & Modification' started by mabman, Jul 6, 2012.

  1. mabman

    mabman Member

    Jun 7, 2007
    Winnipeg, MB
    Several years ago (I think it was 5-7) I picked up a rebuilt Isolette III folder with Prontor SVS shutter and Agfa Apotar lens. I got this from Certo6 (Jurgen Kreckel). It all worked as intended when I got it. Fast forward to the present - mostly due to other cameras I've acquired, the Isolette III has sat unused for 2 or more years.

    I picked it up the other day, cocked and fired the shutter a couple of times (in X mode, which is where I usually leave it), and then tried to cock and fire it again - it wouldn't fire. Further playing around results in:

    - all speeds fire all the time if using V (self-timer)
    - speeds fire occasionally (and sometimes there is a pause of a second or 2 between pressing the shutter button and the shutter actually firing) if moving from one shot on V to one shot on M, but sometimes it doesn't fire at all.
    - no speeds fire on X anymore (the cocking lever remains in the cocked position. If I manually give it a flick with my finger, it will fire.)

    Does this sound salvageable? Is it (potentially) an easy fix? My local repair guy seems to be good with old shutters, so I might get him to do the dirty work, but I'm wondering if anyone else has encountered something like this.

  2. Nick Merritt

    Nick Merritt Member

    Jan 6, 2007
    Hartford, Co
    Multi Format
    Sure -- sounds like it's gummed up some again. Maybe Jurgen didn't thoroughly clean it, or equally likely, it has simply started acting up from lack of use. In any case, it definitely should be salvageable.